Giriş yapmadınız.

Duyuru

TÜRKÇE KİTAP DUYURUSU:
Laravel 5 : Laravel 5.1 Güzelliği (Türkçe)
Vue.js 2 : Vue.js 2 Majesteleri (Türkçe)

#1 07.02.2013 18:04:11

belgelik
Üye
Yer: Ankara
Kayıtlı: 05.02.2013
Mesajlar: 10

Linux Mint Laravel Kurulumunda index.php kaldırma problemi ?

Merhaba;
laravel mintte kurdum ve virtual host ayarlarını yaptım ancak linklerdeki index.php nasıl kaldırıcam ??

virtualhost için;
<VirtualHost *:80>
    ServerAdmin [email protected]
    DocumentRoot /var/www/brc.han/public   
    <Directory /var/www/brc.han/public>
        Options Indexes Includes FollowSymLinks MultiViews
        AllowOverride AuthConfig FileInfo
        Order allow,deny
        Allow from all
    </Directory>
    ServerName brc.han   
</VirtualHost>

tutoriallardaki talimatlara göre yapıyorum her ne kadar onlar mac için göstersede olay aynı ? Helptede  açıklayıcı bir şeyler yok ??
ama bir türlü index.php siz istediğim path gitmiyor ?
teşekkürler

Son düzenleyen belgelik (07.02.2013 18:05:12)

Çevrimdışı

#2 07.02.2013 23:01:11

trueWD
Üye
Yer: İstanbul
Kayıtlı: 26.12.2012
Mesajlar: 29
Website

Yanıt: Linux Mint Laravel Kurulumunda index.php kaldırma problemi ?

Buradaki yazıyı okumanı öneririm.

http://www.sinaneldem.com.tr/laravel-fr … -kurulumu/

Çevrimdışı

#3 07.02.2013 23:24:33

swordfish
Üye
Yer: Salihli
Kayıtlı: 17.01.2013
Mesajlar: 8
Website

Yanıt: Linux Mint Laravel Kurulumunda index.php kaldırma problemi ?

Laravel'i virtual host ile kullaniyorum.
Dun bende ayni problemi yasadim, public dizini altindaki .htaccess dosyasi islenmiyordu.
Soyle cozdum ; "/etc/apache2/sites-available" altindaki ilgili virtual host dosyasindaki 

AllowOverride None

dan 

AllowOverride All

'a cekince apache'i relaod yaptiktan sonra .httaccess dosyasi calisir hale geldi ve index.php kalki.
sizde gördüğüm kadarıyla 

AllowOverride AuthConfig FileInfo

seklinde.
tabi bu guvenlik acisindan problem olustururmu bilemiyorum, su an localde calistigim icin arastirmadim.
calisan public/.htaccess dosyam ;

<IfModule mod_rewrite.c>
	Options +FollowSymLinks
	RewriteEngine On
</IfModule>
<IfModule mod_rewrite.c>
	RewriteCond %{REQUEST_FILENAME} !-f
	RewriteCond %{REQUEST_FILENAME} !-d
	RewriteRule ^(.*)$ index.php/$1 [L]
</IfModule>

Sistem : Debian GNU/Linux 6.0.6 (squeeze)
belki isinize yarar,kolayliklar..

Son düzenleyen swordfish (07.02.2013 23:28:10)

Çevrimdışı

#4 08.02.2013 01:18:37

belgelik
Üye
Yer: Ankara
Kayıtlı: 05.02.2013
Mesajlar: 10

Yanıt: Linux Mint Laravel Kurulumunda index.php kaldırma problemi ?

swordfish yazdı:

Laravel'i virtual host ile kullaniyorum.
Dun bende ayni problemi yasadim, public dizini altindaki .htaccess dosyasi islenmiyordu.
Soyle cozdum ; "/etc/apache2/sites-available" altindaki ilgili virtual host dosyasindaki 

AllowOverride None

dan 

AllowOverride All

'a cekince apache'i relaod yaptiktan sonra .httaccess dosyasi calisir hale geldi ve index.php kalki.
sizde gördüğüm kadarıyla 

AllowOverride AuthConfig FileInfo

seklinde.
tabi bu guvenlik acisindan problem olustururmu bilemiyorum, su an localde calistigim icin arastirmadim.
calisan public/.htaccess dosyam ;

<IfModule mod_rewrite.c>
	Options +FollowSymLinks
	RewriteEngine On
</IfModule>
<IfModule mod_rewrite.c>
	RewriteCond %{REQUEST_FILENAME} !-f
	RewriteCond %{REQUEST_FILENAME} !-d
	RewriteRule ^(.*)$ index.php/$1 [L]
</IfModule>

Sistem : Debian GNU/Linux 6.0.6 (squeeze)
belki isinize yarar,kolayliklar..

cevap için teşekkür ederim acaba /etc/apache2/sites-available dosyasının tam içeriğinide buraya gönderebilirmisiniz ? Hala sorunum çözülmedide..

Çevrimdışı

#5 08.02.2013 08:57:08

sineld
Yönetici
Yer: Bursa
Kayıtlı: 26.12.2012
Mesajlar: 1,405
Website

Yanıt: Linux Mint Laravel Kurulumunda index.php kaldırma problemi ?

Ben yaptığım yöntemi sizinle paylaşayım, aslında bu bile başlıca bir makale konusu; talep çok olursa o makaleyi de yazabilirim.

Ben sites-available içindeki default'un bir kopyasını oluşturuyorum

cp default sineld

sonra sineld içinden gerekli düzenlemeyi yapıp kaydedip kapatıyorum.
ardından etkinleştiriyorum.

a2ensite sineld

Burada fazlasıyla detaylı anlatılmış smile

Çevrimdışı

#6 08.02.2013 13:41:12

belgelik
Üye
Yer: Ankara
Kayıtlı: 05.02.2013
Mesajlar: 10

Yanıt: Linux Mint Laravel Kurulumunda index.php kaldırma problemi ?

sineld yazdı:

Ben yaptığım yöntemi sizinle paylaşayım, aslında bu bile başlıca bir makale konusu; talep çok olursa o makaleyi de yazabilirim.

Ben sites-available içindeki default'un bir kopyasını oluşturuyorum

cp default sineld

sonra sineld içinden gerekli düzenlemeyi yapıp kaydedip kapatıyorum.
ardından etkinleştiriyorum.

a2ensite sineld

Burada fazlasıyla detaylı anlatılmış smile

bende aynı yaptım ancak halen index.php yazmazsam hata veriyor.
Sanırım hostinge aktarınca böyle bir sorunla karşılaşmam ?
Ben CI 'da sadece .htaccess de değişilik yaparak bu olayı çözüyordum ama her ne hikmetse bunda olmadı sad

Çevrimdışı

#7 08.02.2013 15:16:58

swordfish
Üye
Yer: Salihli
Kayıtlı: 17.01.2013
Mesajlar: 8
Website

Yanıt: Linux Mint Laravel Kurulumunda index.php kaldırma problemi ?

admin yazdı:
swordfish yazdı:

Laravel'i virtual host ile kullaniyorum.
Dun bende ayni problemi yasadim, public dizini altindaki .htaccess dosyasi islenmiyordu.
Soyle cozdum ; "/etc/apache2/sites-available" altindaki ilgili virtual host dosyasindaki 

AllowOverride None

dan 

AllowOverride All

'a cekince apache'i relaod yaptiktan sonra .httaccess dosyasi calisir hale geldi ve index.php kalki.
sizde gördüğüm kadarıyla 

AllowOverride AuthConfig FileInfo

seklinde.
tabi bu guvenlik acisindan problem olustururmu bilemiyorum, su an localde calistigim icin arastirmadim.
calisan public/.htaccess dosyam ;

<IfModule mod_rewrite.c>
	Options +FollowSymLinks
	RewriteEngine On
</IfModule>
<IfModule mod_rewrite.c>
	RewriteCond %{REQUEST_FILENAME} !-f
	RewriteCond %{REQUEST_FILENAME} !-d
	RewriteRule ^(.*)$ index.php/$1 [L]
</IfModule>

Sistem : Debian GNU/Linux 6.0.6 (squeeze)
belki isinize yarar,kolayliklar..

cevap için teşekkür ederim acaba /etc/apache2/sites-available dosyasının tam içeriğinide buraya gönderebilirmisiniz ? Hala sorunum çözülmedide..

mylv adli virtual host dosyam;

#	
#	Virtual Host Site Template
#	Author		: skeser
#	Version	: 0.1 - 29.01.2013 23:36
 

<VirtualHost *:80>
	# ServerAdmin sample : [email protected]
       ServerAdmin	[email protected] 	
	Servername	mylv		
	ServerAlias	mylv
	
	DocumentRoot /home/arge/public_html/mylv/public
        <Directory />
                Options FollowSymLinks
                AllowOverride All
        </Directory>
	# Directory sample: <Directory /home/arge/public_html/>
       <Directory /home/arge/public_html/mylv/public/>
                Options Indexes FollowSymLinks MultiViews
                AllowOverride All
                Order allow,deny
                allow from all
        </Directory>
	# ScriptAlias sample : /cgi-bin/ /home/arge/public_html/cgi-bin/
       # ScriptAlias sample : /cgi-bin/ /home/arge/public_html/mylv/cgi-bin/
	# Directory for cgi-bin  sample : <Directory "/home/arge/public_html/cgi-bin">
       # <Directory "/home/arge/public_html/mylv/cgi-bin">
       #         AllowOverride None
       #         Options +ExecCGI -MultiViews +SymLinksIfOwnerMatch
       #         Order allow,deny
       #         Allow from all
       # </Directory>

        ErrorLog /home/arge/public_html/mylv/logs/error.log

        # Possible values include: debug, info, notice, warn, error, crit,
        # alert, emerg.
        LogLevel warn

        CustomLog /home/arge/public_html/mylv/logs/access.log combined
</VirtualHost>
bende aynı yaptım ancak halen index.php yazmazsam hata veriyor.

bu bahsettginiz hata nedir ?
page not found' mu yoksa htaccess ayarıyla ilgili bir hata mı ?
birde yukaridaki configrasyon dosyasinda, error.log ve access.log dosyalarina ne gozukuyor.
yukaridaki ayar dosyasina gore ;
1- iki adet consol acin,
ilkinde : $ tail -f logs/access.log
ikinci konsolda : $ tail -f logs/error.log
2- sonra hata aldiğiniz sayfayi browser'dan refresh edin, bakalim ne yumurtlayacak ?

Çevrimdışı

#8 08.02.2013 16:09:47

belgelik
Üye
Yer: Ankara
Kayıtlı: 05.02.2013
Mesajlar: 10

Yanıt: Linux Mint Laravel Kurulumunda index.php kaldırma problemi ?

swordfish yazdı:
admin yazdı:
swordfish yazdı:

Laravel'i virtual host ile kullaniyorum.
Dun bende ayni problemi yasadim, public dizini altindaki .htaccess dosyasi islenmiyordu.
Soyle cozdum ; "/etc/apache2/sites-available" altindaki ilgili virtual host dosyasindaki 

AllowOverride None

dan 

AllowOverride All

'a cekince apache'i relaod yaptiktan sonra .httaccess dosyasi calisir hale geldi ve index.php kalki.
sizde gördüğüm kadarıyla 

AllowOverride AuthConfig FileInfo

seklinde.
tabi bu guvenlik acisindan problem olustururmu bilemiyorum, su an localde calistigim icin arastirmadim.
calisan public/.htaccess dosyam ;

<IfModule mod_rewrite.c>
	Options +FollowSymLinks
	RewriteEngine On
</IfModule>
<IfModule mod_rewrite.c>
	RewriteCond %{REQUEST_FILENAME} !-f
	RewriteCond %{REQUEST_FILENAME} !-d
	RewriteRule ^(.*)$ index.php/$1 [L]
</IfModule>

Sistem : Debian GNU/Linux 6.0.6 (squeeze)
belki isinize yarar,kolayliklar..

cevap için teşekkür ederim acaba /etc/apache2/sites-available dosyasının tam içeriğinide buraya gönderebilirmisiniz ? Hala sorunum çözülmedide..

mylv adli virtual host dosyam;

#	
#	Virtual Host Site Template
#	Author		: skeser
#	Version	: 0.1 - 29.01.2013 23:36
 

<VirtualHost *:80>
	# ServerAdmin sample : [email protected]
       ServerAdmin	[email protected] 	
	Servername	mylv		
	ServerAlias	mylv
	
	DocumentRoot /home/arge/public_html/mylv/public
        <Directory />
                Options FollowSymLinks
                AllowOverride All
        </Directory>
	# Directory sample: <Directory /home/arge/public_html/>
       <Directory /home/arge/public_html/mylv/public/>
                Options Indexes FollowSymLinks MultiViews
                AllowOverride All
                Order allow,deny
                allow from all
        </Directory>
	# ScriptAlias sample : /cgi-bin/ /home/arge/public_html/cgi-bin/
       # ScriptAlias sample : /cgi-bin/ /home/arge/public_html/mylv/cgi-bin/
	# Directory for cgi-bin  sample : <Directory "/home/arge/public_html/cgi-bin">
       # <Directory "/home/arge/public_html/mylv/cgi-bin">
       #         AllowOverride None
       #         Options +ExecCGI -MultiViews +SymLinksIfOwnerMatch
       #         Order allow,deny
       #         Allow from all
       # </Directory>

        ErrorLog /home/arge/public_html/mylv/logs/error.log

        # Possible values include: debug, info, notice, warn, error, crit,
        # alert, emerg.
        LogLevel warn

        CustomLog /home/arge/public_html/mylv/logs/access.log combined
</VirtualHost>
bende aynı yaptım ancak halen index.php yazmazsam hata veriyor.

bu bahsettginiz hata nedir ?
page not found' mu yoksa htaccess ayarıyla ilgili bir hata mı ?
birde yukaridaki configrasyon dosyasinda, error.log ve access.log dosyalarina ne gozukuyor.
yukaridaki ayar dosyasina gore ;
1- iki adet consol acin,
ilkinde : $ tail -f logs/access.log
ikinci konsolda : $ tail -f logs/error.log
2- sonra hata aldiğiniz sayfayi browser'dan refresh edin, bakalim ne yumurtlayacak ?

hehe logları kontrol ettim de mutluluğu uzaklarda aramaya gerek yokmuş smile))

hmm Sorun bende dikkatsizliğim sites-avaible altındaki çakma domaine ait vhosts dosyasında sizin dediğiniz yerdeki AllowOverride None ikitane varmış sad(
Sorunum çözüldü şimdi smile)
Yardımınız için teşekkür ederim.
(Bu arada page not found hatasıydı ama sorun çözülünce pek bi önemide kalmadı sanırım smile)

Çevrimdışı

#9 08.02.2013 22:53:31

swordfish
Üye
Yer: Salihli
Kayıtlı: 17.01.2013
Mesajlar: 8
Website

Yanıt: Linux Mint Laravel Kurulumunda index.php kaldırma problemi ?

admin yazdı:

hmm Sorun bende dikkatsizliğim sites-avaible altındaki çakma domaine ait vhosts dosyasında sizin dediğiniz yerdeki AllowOverride None ikitane varmış sad(
Sorunum çözüldü şimdi smile)
Yardımınız için teşekkür ederim.
(Bu arada page not found hatasıydı ama sorun çözülünce pek bi önemide kalmadı sanırım smile)

evet, .htaccess dosyasi islenmiyormus.
index.php kaldirmayla ilgli olarak;
son olarak şunuda ekleyelim ki google aramayla gelecek arkadaslar icin eksik bir sey kalmasin;
application\config\application.php icersinde,

'index' => 'index.php',

satirini asagidaki sekliyle duzeltiyoruz.

'index' => '',

kolayliklar..

Çevrimdışı

#10 09.02.2013 00:10:40

sineld
Yönetici
Yer: Bursa
Kayıtlı: 26.12.2012
Mesajlar: 1,405
Website

Çevrimdışı

Forum alt kısmı