Giriş yapmadınız.

Duyuru

TÜRKÇE KİTAP DUYURUSU:
Laravel 5 : Laravel 5.1 Güzelliği (Türkçe)
Vue.js 2 : Vue.js 2 Majesteleri (Türkçe)

#1 14.11.2017 21:23:37

DucaN
Üye
Kayıtlı: 14.11.2017
Mesajlar: 8

Hazır yazılmış olan paket hakkında

Merhabalar Hocalarım,

laravel ile ilgili dökümanları gezince github da lavalite diye bir yazılmış olan bir panel gördüm ve admin paneli çok hoşuma gitti fakat bunu bir türlü kuramadım

ilgili dökümanda eksik veya başaramadığım bir durum söz konusu bunu localde bir türlü görüntüleyemiyorum yardımcı olurmusunuz nasıl yapacağım bilemedim sad

https://lavalite.readme.io/

Çevrimdışı

#2 14.11.2017 21:45:53

irmakcosarsahna
Üye
Kayıtlı: 30.10.2017
Mesajlar: 14

Yanıt: Hazır yazılmış olan paket hakkında

Sorun nedir acaba? İlk defa gördün Linkten inceledim bu paket değil öncelikle bildiğiniz laravel blog cms uygulaması gibi bir proje. indirip klasör içinde composer install dedikten sonra .env dosyasını düzenliceksiniz.

Son düzenleyen irmakcosarsahna (14.11.2017 21:46:41)

Çevrimdışı

#3 14.11.2017 21:48:53

DucaN
Üye
Kayıtlı: 14.11.2017
Mesajlar: 8

Yanıt: Hazır yazılmış olan paket hakkında

.env yi neye göre düzenliyeceğim bunu örnekleyebilirmisiniz?

Çevrimdışı

#4 14.11.2017 21:51:30

irmakcosarsahna
Üye
Kayıtlı: 30.10.2017
Mesajlar: 14

Yanıt: Hazır yazılmış olan paket hakkında

.env.example dosyası var onun sonundaki .example sileceksin. Ardından düzenlediğin .env dosyası içerisindeki veritabanı bilgilerini giriceksin ardından composer install diyip yükleteceksin eğer migrasyonlar varsa php artisan migrate yapıcaksın consolda otomatik yüklenecek, kullanıma hazır olur.

Son düzenleyen irmakcosarsahna (14.11.2017 21:55:25)

Çevrimdışı

#5 15.11.2017 12:17:42

DucaN
Üye
Kayıtlı: 14.11.2017
Mesajlar: 8

Yanıt: Hazır yazılmış olan paket hakkında

komut satırına bunu yazıyorum ve hemen atındaki hata kodlarını alıyorum ne yapmam gerekiyor sad
C:\xampp\htdocs\lavalite>php artisan migrate --seed
PHP Warning:  require(C:\xampp\htdocs\lavalite\bootstrap/../vendor/autoload.php): failed to open stream: No such file or directory in C:\xampp\htdocs\lavalite\bootstrap\autoload.php
on line 17

Warning: require(C:\xampp\htdocs\lavalite\bootstrap/../vendor/autoload.php): failed to open stream: No such file or directory in C:\xampp\htdocs\lavalite\bootstrap\autoload.php on li
ne 17
PHP Fatal error:  require(): Failed opening required 'C:\xampp\htdocs\lavalite\bootstrap/../vendor/autoload.php' (include_path='C:\xampp\php\PEAR') in C:\xampp\htdocs\lavalite\bootst
rap\autoload.php on line 17

Fatal error: require(): Failed opening required 'C:\xampp\htdocs\lavalite\bootstrap/../vendor/autoload.php' (include_path='C:\xampp\php\PEAR') in C:\xampp\htdocs\lavalite\bootstrap\a
utoload.php on line 17

buda .env deki bilgilerim
APP_ENV=local
APP_KEY=
APP_DEBUG=true
APP_LOG_LEVEL=debug
APP_URL=http://localhost

DB_CONNECTION=mysql
DB_HOST=127.0.0.1
DB_PORT=3306
DB_DATABASE=deneme
DB_USERNAME=root
DB_PASSWORD=

BROADCAST_DRIVER=log
CACHE_DRIVER=file
SESSION_DRIVER=file
QUEUE_DRIVER=sync

REDIS_HOST=127.0.0.1
REDIS_PASSWORD=null
REDIS_PORT=6379

MAIL_DRIVER=smtp
MAIL_HOST=mailtrap.io
MAIL_PORT=2525
MAIL_USERNAME=null
MAIL_PASSWORD=null
MAIL_ENCRYPTION=null

PUSHER_KEY=
PUSHER_SECRET=
PUSHER_APP_ID=

GMAP_API=

Çevrimdışı

#6 15.11.2017 12:22:55

DucaN
Üye
Kayıtlı: 14.11.2017
Mesajlar: 8

Yanıt: Hazır yazılmış olan paket hakkında

https://lavalite.readme.io/docs/getting-started buranın en atında birde şöyle birşey yazıyor

Windows'ta

Windows ortamı kullanıyorsanız, paketleri boşaltırken yol uzunluğu ile ilgili sorunlarla karşılaşabilirsiniz. Bu sorunu önlemek için bunun yerine --prefer-source bayrağını kullanın.

bu bahsi geçen  --prefer-source nasıl kullanabilirim.

Çevrimdışı

#7 15.11.2017 12:39:56

irmakcosarsahna
Üye
Kayıtlı: 30.10.2017
Mesajlar: 14

Yanıt: Hazır yazılmış olan paket hakkında

Öncelikle senin laravel api keyin yok consolda  php artisan key:generate dedikten sonra işlemleri tekrar dene Bu arada laravel 5.5 de eğer mysql sürümün MySQL v5.7.7  den düşük ise AppServiceProvider.php dosyası aşağıdaki gibi yapman gerekecek. ardından bu  işlemleri yaptıktan sonra tekrar dene bakalım

use Illuminate\Support\Facades\Schema;

public function boot()
{
    Schema::defaultStringLength(191);
}

Çevrimdışı

#8 15.11.2017 13:15:19

mgsmus
Moderatör
Yer: Mersin
Kayıtlı: 17.08.2013
Mesajlar: 838
Website

Yanıt: Hazır yazılmış olan paket hakkında

DucaN yazdı:

https://lavalite.readme.io/docs/getting-started buranın en atında birde şöyle birşey yazıyor

Windows'ta

Windows ortamı kullanıyorsanız, paketleri boşaltırken yol uzunluğu ile ilgili sorunlarla karşılaşabilirsiniz. Bu sorunu önlemek için bunun yerine --prefer-source bayrağını kullanın.

bu bahsi geçen  --prefer-source nasıl kullanabilirim.

Composer parametresi. Yani şöyle kullanıyorsunuz:

composer create-project LavaLite/cms --prefer-source website

ama Windows'da dosya yolu uzunluğu problemi ile pek karşılaştığımı söyleyemem. Bazen zip içinde zip içinde zip... oluyor, onların klasör izinleri isimleri uzunsa içi içe klasörler oluşunca sorun oluyor ama çok çok nadir. Zaten regedit ile de yol adı uzunluğu problemi çözülüyor bildiğim kadarıyla. Sorun yaşamıyorsanız --prefer-dist kullanın.

Son düzenleyen mgsmus (15.11.2017 13:16:59)

Çevrimdışı

#9 15.11.2017 13:18:17

mgsmus
Moderatör
Yer: Mersin
Kayıtlı: 17.08.2013
Mesajlar: 838
Website

Yanıt: Hazır yazılmış olan paket hakkında

DucaN yazdı:

komut satırına bunu yazıyorum ve hemen atındaki hata kodlarını alıyorum ne yapmam gerekiyor sad
C:\xampp\htdocs\lavalite>php artisan migrate --seed
PHP Warning:  require(C:\xampp\htdocs\lavalite\bootstrap/../vendor/autoload.php): failed to open stream: No such file or directory in C:\xampp\htdocs\lavalite\bootstrap\autoload.php
on line 17

Warning: require(C:\xampp\htdocs\lavalite\bootstrap/../vendor/autoload.php): failed to open stream: No such file or directory in C:\xampp\htdocs\lavalite\bootstrap\autoload.php on li
ne 17
PHP Fatal error:  require(): Failed opening required 'C:\xampp\htdocs\lavalite\bootstrap/../vendor/autoload.php' (include_path='C:\xampp\php\PEAR') in C:\xampp\htdocs\lavalite\bootst
rap\autoload.php on line 17

Fatal error: require(): Failed opening required 'C:\xampp\htdocs\lavalite\bootstrap/../vendor/autoload.php' (include_path='C:\xampp\php\PEAR') in C:\xampp\htdocs\lavalite\bootstrap\a
utoload.php on line 17

buda .env deki bilgilerim
APP_ENV=local
APP_KEY=
APP_DEBUG=true
APP_LOG_LEVEL=debug
APP_URL=http://localhost

DB_CONNECTION=mysql
DB_HOST=127.0.0.1
DB_PORT=3306
DB_DATABASE=deneme
DB_USERNAME=root
DB_PASSWORD=

BROADCAST_DRIVER=log
CACHE_DRIVER=file
SESSION_DRIVER=file
QUEUE_DRIVER=sync

REDIS_HOST=127.0.0.1
REDIS_PASSWORD=null
REDIS_PORT=6379

MAIL_DRIVER=smtp
MAIL_HOST=mailtrap.io
MAIL_PORT=2525
MAIL_USERNAME=null
MAIL_PASSWORD=null
MAIL_ENCRYPTION=null

PUSHER_KEY=
PUSHER_SECRET=
PUSHER_APP_ID=

GMAP_API=

Öncelikle C:\xampp\htdocs\lavalite içerisinde vendor klasörü varsa silin. Sonra aynı klasörde komut satırından composer install ile composer paketlerini tekrar kurun

Son düzenleyen mgsmus (15.11.2017 13:18:33)

Çevrimdışı

#10 15.11.2017 13:19:26

mgsmus
Moderatör
Yer: Mersin
Kayıtlı: 17.08.2013
Mesajlar: 838
Website

Yanıt: Hazır yazılmış olan paket hakkında

Son olarak da konuyla ilgili olarak şuna da bakabilirsiniz:
https://laravelvoyager.com/

Çevrimdışı

#11 15.11.2017 13:23:19

DucaN
Üye
Kayıtlı: 14.11.2017
Mesajlar: 8

Yanıt: Hazır yazılmış olan paket hakkında

hocam dediğinizi yaptım

php artisan key:generate
dediğimde en başta belirttiğim hatayı aldım tekrar ve diğer bahsetmiş olduğunuz AppServiceProvider.php dosyasındada ilgili değişiklikleri yaptım malesef sonuç alamadım

Çevrimdışı

#12 15.11.2017 15:01:37

DucaN
Üye
Kayıtlı: 14.11.2017
Mesajlar: 8

Yanıt: Hazır yazılmış olan paket hakkında

php artisan key:generate yazdığımda  ağaıdaki hatayı alıyorum aslında astisan ile ilgili ne yaparsam bu hatayı alıyorum sad
C:\xampp\htdocs\website>php artisan key:generate
PHP Warning:  require(C:\xampp\htdocs\website\bootstrap/../vendor/autoload.php): failed to open stream: No such file or directory in C:\xampp\htdocs\website\bootstrap\autoload.p
hp on line 17

Warning: require(C:\xampp\htdocs\website\bootstrap/../vendor/autoload.php): failed to open stream: No such file or directory in C:\xampp\htdocs\website\bootstrap\autoload.php on
line 17
PHP Fatal error:  require(): Failed opening required 'C:\xampp\htdocs\website\bootstrap/../vendor/autoload.php' (include_path='C:\xampp\php\PEAR') in C:\xampp\htdocs\website\boo
tstrap\autoload.php on line 17

Fatal error: require(): Failed opening required 'C:\xampp\htdocs\website\bootstrap/../vendor/autoload.php' (include_path='C:\xampp\php\PEAR') in C:\xampp\htdocs\website\bootstra
p\autoload.php on line 17

Çevrimdışı

#13 15.11.2017 20:55:56

ak
Üye
Yer: İstanbul
Kayıtlı: 12.07.2014
Mesajlar: 78

Yanıt: Hazır yazılmış olan paket hakkında

Merhaba,
Xampp yerine laragon ( https://laragon.org )  kullanabilirsiniz.  Daha evvel 2.x sürümlerini kullanmıştım, laravel için herşey hazırdı.
İyi çalışmalar.

Çevrimdışı

#14 17.11.2017 18:15:23

DucaN
Üye
Kayıtlı: 14.11.2017
Mesajlar: 8

Yanıt: Hazır yazılmış olan paket hakkında

ak yazdı:

Merhaba,
Xampp yerine laragon ( https://laragon.org )  kullanabilirsiniz.  Daha evvel 2.x sürümlerini kullanmıştım, laravel için herşey hazırdı.
İyi çalışmalar.

çok teşekkür ederim bu işe yaradı ayriyeten çok başarılı yazılım hmm

Çevrimdışı

Forum alt kısmı