Giriş yapmadınız.

Duyuru

TÜRKÇE KİTAP DUYURUSU:
Laravel 5 : Laravel 5.1 Güzelliği (Türkçe)
Vue.js 2 : Vue.js 2 Majesteleri (Türkçe)

#1 21.06.2013 12:49:04

fatihetsiz
Üye
Kayıtlı: 21.06.2013
Mesajlar: 3

[Çözüldü] Veritabanı encoding sorunu

Çok amatörce ama anlamadım nereden kaynaklandığını.
CI'da böyle sorun yaşamadım phpmyadmin varsayılan encoding kullanıyordum.

L3'te bir cms yapıyorum. Kullanı ve kategori için ekleme - düzenleme - silme işlemlerini kodladım..

Sonra FW'de utf8 kodlama kontrol ettim. Sublime 2 kullanıyorum. Kendi hazırladığım dosyaları utf8 olarak kayıt ettim.
phpmyadmin varsayılan encoding kullanıyorum.

Tüm kayıtlarımda türkçe karaktekler soru işareti olarak DB kayıt oluyor.

DB'nin encoding durumunu utf8-general-ci olrak denedim laravel hata verdi.

bu konuda çözümü olan var mı?

Çevrimdışı

#2 21.06.2013 13:18:02

fatihetsiz
Üye
Kayıtlı: 21.06.2013
Mesajlar: 3

Yanıt: [Çözüldü] Veritabanı encoding sorunu

Kendim çözdüm sorunu.

nettede bununla ilgili çözüm yoktu.

DB, Table için phpmyadmin'den encoding varsayılan olarak utf8-general-ci ayarlarsanız sorun çözülüyor.

artisan kullandığınızda bu kodlama ile oluşuyor db ve table..

Çevrimdışı

#3 27.06.2013 17:22:16

sineld
Yönetici
Yer: Bursa
Kayıtlı: 26.12.2012
Mesajlar: 1,405
Website

Çevrimdışı

#4 11.01.2014 15:24:17

fsielsones
Üye
Kayıtlı: 11.01.2014
Mesajlar: 1

Yanıt: [Çözüldü] Veritabanı encoding sorunu

Thanks, I also solve the problem with the information provided. It is really happy.

Çevrimdışı

Forum alt kısmı